Plesk

Greylisting defers emails from senders that use multiple IP addresses

Symptoms

Cause

This is expected behavior when greylisting is enabled: The first message is rejected, and the next message sent from the same address (sender server IP address and 'From:') will be accepted after a certain length of time passes. So if an email address is the same, but IP address is different, emails from this email address will be rejected.

For example, emails from *protection.outlook.com are sent from multiple IP addresses. This causes greylisting treat every new retry as a new message, so there is a delay in message delivery until the same pair of email/IP address is logged.

Resolution

Set up a server-wide white-list for Office 365 domains - a list of hosts which emails will be accepted without greylisting check-ups:

  1. Connect to the Plesk server via SSH.

  2. Add the main part of a sender hostname in the command below (in this example, it is for Office365) and run it:

    # /usr/local/psa/bin/grey_listing -u -domains-whitelist add:*outbound.protection.outlook.com

    To learn more about greylisting configuration options, visit this KB article.

 

To make sure that the network allows connections from all Exchange Online Protection (EOP) IP address ranges., visit this Microsoft Docs page.

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