Plesk

FTP login fails on Plesk server: 530 User cannot log in, home directory inaccessible. Login failed

Symptoms

Cause

Wrong path in FTP_ROOT_D key in the registry database.

Resolution

Note: if direct RDP access to the server is not possible, contact server administrator for further assistance.

  1. Connect to the server via RDP

  2. Check the physical path for FTP sites in IIS > Hostname > Sites > 203.0.113.2 > Basic settings > Physical Path (e.g. C:InetpubvhostsServers). 

  3. Open Registry Editor in Start > Run and type regedit.

  4. Navigate to HKEY_LOCAL_MACHINESOFTWAREWow6432NodePLESKPSA ConfigConfig

  5. Check the FTP_ROOT_D path and verify it corresponds to the existing physical directory. The path present on FTP_ROOT_D should be same of Physical Path in IIS. (e.g: C:InetpubvhostsServers).