Plesk

Failed to add the domain ‘example.com’ into SpamExperts extension for Plesk: The domain ‘example.com’ does not belong to the admin ‘plesk_1234568_1’.

Symptoms

Cause

Issue is on SpamExperts side: The error indicates that the domain belongs to a different account on SpamExpert side. It may happen if the domain was protected with SpamExpert in past (with different SpamExpert license, for example) and the domain is still linked to another account (old one) on SpamExpert side.

Resolution

  1. Log into Plesk.

  2. Go to Domains > example.com > DNS Settings

  3. Remove all MX records which are pointing to *.spamexperts.*

  4. Add new MX record mail.example.com for the domain in Domains > example.com > DNS settings > Add Record

  5. Protect domain again by selecting domain example.com in Extensions > My Extensions > SpamExperts Email Security > Domains and click Protect

    Note: If solution above does not help, contact SpamExperts support for assistance using the form in the extension: Extensions > SpamExpert Email Security > Support