Plesk

Emails that are sent locally inside the server are rejected with “DMARC: REJECT message” or “DMARC: message moved to QUARANTINE”

Symptoms

Cause

This is a Plesk bug with ID PPPM-7190, which is planned to be fixed in future product updates.

Resolution

Apply one of the following workarounds:

 

Workaround I

  1. Check the "Return-Path" value from the email header which was moved to spam:

    Return-Path: <mail@example.com>

  2. Connect to the Plesk server via SSH.

  3. Whitelist the domain from "Return-Path" by adding its name to the "IgnoreMailFrom" string in the file /etc/psa/dmarc.conf:

    3.1. Create the file /etc/psa/dmarc.conf:

    # touch /etc/psa/dmarc.conf

    3.2. Open the file in a text editor. In this example, we are using the vi editor:

    # vi /etc/psa/dmarc.conf

    3.3. Add the required domains as a line after 'IgnoreMailFrom':

    Note: Replace example.com with actual domain name(s).

    IgnoreMailFrom example.com, example.net, example.org

    3.4. Save the changes and close the file.

 

Workaround II

Modify the DMARC record of the recipient domain: Change "p=quarantine" or "p=reject" to "p=none" at Domains > example.com > DNS Settings.