Plesk

Emails sent from Plesk server are stuck in mail queue: deferred, Connection timed out

Symptoms

Cause

Firewall configuration on the recipient mail server blocks connections from the Plesk server.


MX records list for the recipient domain contains outdated record(s).

Resolution

Contact the owners of the recipient domain example.com so they revise the MX records list to contain correct IP addresses and allow connections over port 25 on the firewalls of their mail servers.

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