Plesk

Emails go to Spam: DKIM record is corrupted

Symptoms

Cause

DKIM record is corrupted.

Resolution

  1. Log into Plesk
  2. Go to Domains > example.com > Mail Settings.
  3. Disable the Use DKIM spam protection system to sign outgoing email messages option.
  4. Press the Apply button.
  5. Enable the Use DKIM spam protection system to sign outgoing email messages option.
  6. Press the OK to button to generate a new DKIM record.

Note: on Plesk for Windows the DKIM record is recreated instead of regenerating, this is enough for the case when the DKIM record is broken. 

Note: is DNS is hosted externally, manually copy default._domainkey.example.com record to the external DNS server