Plesk

Emails are not sent from a Plesk server with the errors “25: Connection timed out” and “25: Network is unreachable”

Symptoms

Cause

A private IP address is used for outgoing emails.

Resolution

  1. Log in to Plesk.

  2. Go to Tools and Settings > Mail Server Settings.

  3. Set Outgoing mail mode to some public IP address.

Exit mobile version