Plesk

Emails are not delivered to the particular recipient in Plesk: marked message to be discarded if not explicitly delivered (discard action)

Symptoms

Cause

Custom Sieve rule is configured to discard a specific recipient mailbox.

The following configuration exists in the *.sieve file under /var/qmail/mailnames/example.com/john.doe/sieve/ directory:

# Blacklisted Addresses
...
if address :all :comparator "i;ascii-casemap" :is ["From", "Sender", "Resent-From"] ["john.doe1@example.org", "john.doe@example.com"] {
discard;
stop;
}


# rule:[.]
if true
{
discard;
}

Resolution

  1. Login into Webmail.

  2. Define the custom filtering Sieve rule:

    • For Roundcube: in Settings > Filters.
    • For Horde: in Mail > Filters menu.
  3. Modify/remove the rule that blocks some or all senders.

Solution via SSH:

  1. Connect to the server via SSH.

  2. Open the file in any text editor, for example, in vi text editor:

    • For Roundcube:

      # vi /var/qmail/mailnames/example.com/john.doe/sieve/roundcube.sieve

    • For Horde:

      # vi /var/qmail/mailnames/example.com/john.doe/sieve/ingo.sieve

  3. Remove the lines containing the discard rule, for example:

    # rule:[.]
    if true
    {
    discard;
    }

  4. Apply changes and close the file.