Plesk

Default Plesk web page or other incorrect web page is shown

Symptoms

Cause

A different document is processed before the desired Index file on Plesk for Linux or Default document on Plesk for Windows.

Resolution

Note: The desired index file (Linux) or default document (Windows) depends on the website application. To find the correct filename, contact the website developer.

Change index file load order:

For Plesk for Linux

  1. Log into Plesk
  2. Go to Domains > example.com > Apache & Nginx Settings
  3. Enable checkbox Enter values for Index files
  4. Remove the line with unwanted document from the list, or place the desired index filename to the first line
  5. Click OK

For Plesk for Windows

  1. Log into Plesk
  2. Go to Domains > example.com > IIS Settings
  3. Enable checkbox Enter values for Default documents
  4. Remove the line which is not the default document filename from the list, or place the desired default document filename to the first line
  5. Click OK

Alternatively, remove unwanted document which is not the Index file or Default document in website's document root:

  1. Log into Plesk
  2. Go to Domains > example.com > File Manager
  3. Open domain's document root directory, for example folder httpdocs
  4. Rename or delete the incorrect file which is served before the desired document, for example the file index.html: