Plesk

Customers do not see their parts of server backup in Plesk if it is saved in remote storage (FTP, Google Drive, S3)

Symptoms

The subscription owners cannot see/restore their parts from the server backup via Domains > example.com > Backup Settings if it is saved in remote storage (FTP, Google Drive, S3):

Cause

This behavior is expected when server-wide Plesk backups are saved on external storage. Customers (subscriptions) will not see their parts of the server backup, e.g. at Domains > example.com > Backup Settings.

The reason is that only the server administrator has access to the remote storage configured at Tools & Settings > Backup Manager > Remote Storage Settings.
Also, remote backup is stored as one compressed archive file and the backup manager cannot analyze it and show only a part related to the current domain.

Resolution

To enable customers to restore their own part from the server backup via Domains > example.com > Backup Manager, the server backup should be saved locally on the server.

Alternatively, Plesk Administrator can restore the subscription/domain from the full server backup via Plesk > Tools & Settings > Backup Manager.