Plesk

Could not update license. Make sure connections to ka.plesk.com license server on TCP port 443 are not blocked

Symptoms

Unable to install license:

Make sure connections to ka.plesk.com license server on TCP port 443 are not blockedĀ 

Cause

Unclear. ka,plesk.com is accessible from server. Unknown error appear in log:

# tail -fn0 /var/log/plesk/panel.log
[2022-03-18 09:58:34.334] 18447:623490082ef0c ERR [panel] KA Request Failure code: 2 Network failure
...
* Could not resolve host: id-00.kaid.plesk.com; Unknown error
* Closing connection 1

Resolution

Restart Plesk services:

# systemctl restart sw-engine && systemctl restart sw-cp-server

Exit mobile version