Plesk

ClamAV Antivirus error in Plesk: Failed to start clamd@scan.service: Unit not found.

Symptoms

Cause

Incorrect ClamAV packages are installed when the Atomic repository is enabled on the server:

# yum repolist enabled | grep atomic
*atomic: www4.atomicorp.com
atomic/7/x86_64 CentOS / Red Hat Enterprise Linux 7 - atomic 930

Resolution

  1. Log in to Plesk.

  2. Remove Plesk Email Security extension via Extensions > Plesk Email Security > More > Remove:

  3. Connect to the server via SSH.

  4. Find all the ClamAV packages, for example:

    # rpm -qa | grep clam
    clamd-0.102.3-13765.el7.art.x86_64
    clamav-milter-debuginfo-0.104.3-25721.el8.art.x86_64
    clamav-db-0.104.3-25721.el8.art.x86_64

    And remove them using the commands below:

    # yum remove clamd-0.102.3-13765.el7.art.x86_64
    # yum remove clamav-milter-debuginfo-0.104.3-25721.el8.art.x86_64
    # yum remove clamav-db-0.104.3-25721.el8.art.x86_64

  5. Disable the Atomic repository:

    # yum-config-manager --disable atomic

  6. Reinstall Plesk Email Security under Plesk > Extensions > Plesk Email Security > Get it Free:

  7. Go to Extensions > Plesk Email Security and install all the required components again along with ClamAV.