Plesk

[BUG] Customize Plesk URL configured with a specific domain or subdomain doesn’t work correctly: all domains show Plesk login page

Symptoms

All domains on a Plesk server are showing Plesk login page when option The specified domain or subdomain that resolves to the server IP address but is not used for hosting is enabled in Tools & Settings > Customize Plesk URL

Cause

Product issue:

  • #PPPM-12289 "Browsing a domain without hosting or the Plesk server’s hostname via HTTPS now correctly shows the default page instead of the Plesk login page."

    Fixed in:

Resolution

Please consider updating your server:

Workaround

If update is not possible for some reason you may try the following

workaround

Until the bug is fixed, use the following workaround: disable the customized Plesk URL so that Plesk GUI is only accessible via port 8443:

  1. Log in to Plesk GUI

  2. Go to Tools & Settings > Customize Plesk URL > Select the option No custom URLs: Only https://<server-IP-or-hostname>:8443 >

  3. Click OK to apply the changes