Plesk

ASP.NET or other components installed not via Plesk are not detected at Server Components menu

Symptoms

Cause

Product issue:

  • #PPPM-13797 "Clicking Refresh on the Tools & Settings > Server Components screen now results in the list of installed components being updated as intended."
    Fixed in:

Resolution

Please consider updating your server:

Workaround

If update is not possible for some reason you may try the following

workaround

  1. Connect to the server via RDP.

  2. Execute command below via CMD to force the components' update:

    plesk sbin defpackagemng --get --force