Plesk

Application pools are crashing on Plesk for Windows Server: The Module DLL C:pathtomodule_name.dll failed to load. The data is the error.

Symptoms

Cause

The module defined in IIS configuration is improperly configured.

Resolution

  1. Connect to the Plesk server via RDP.

  2. Start a Command Prompt as an Administrator.

  3. Create a backup of IIS configuration:

    C:> %windir%system32inetsrvappcmd.exe add backup BeforeEditBackup

    Note: The backup will be created in
    C:WindowsSystem32inetsrvbackup
    .

  4. Start Internet Information Services (IIS) Manager at Windows Start > All Programs > Administrative Tools.

  5. In IIS Manager, click on SERVERNAME > Modules and remove the faulty module reported in the error message.

    Note: In case the module is not visible on the modules page, move to step 6.

  6. Open the file
    %windir%system32inetsrvconfigApplicationHost.config
    in a text editor and remove the lines related to the faulty module (if exist).
    For example:

    <add name="CSPms" image="C:InetpubCSPGatewayCSPms.dll" />

  7. Save the changes.

  8. Restart IIS:

    C:> iisreset

 

 

Exit mobile version