Plesk

Apache or Nginx webservers are restarted frequently: GENERIC: error receiving data — Resource temporarily unavailable

Symptoms

Cause

Nginx or Apache is being restarted by Watchdog due to the false-negative protocol test.
This is likely to happen due to the short connection timeout value.

Resolution

  1. Log in to Plesk.

  2. Increase Connection timeout value for nginx in Extensions > My Extensions > Watchdog > Web Proxy Server (Nginx):

    Or increase Connection timeout value for Apache in Extensions > My Extensions > Watchdog > Open > Web Server (Apache):

Exit mobile version