Symptoms
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Opening a website/webmail results in the following error:
ERR_CONNECTION_REFUSED
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Proxy mode is enabled under Plesk > Domains > example.com > Apache & Nginx Settings.
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In Plesk > Domains > example.com > Logs or in
/var/www/vhosts/example.com/logs/proxy_error_log
the following record can be found:[error] 31160#0: *35 connect() failed (111: Connection refused) while connecting to upstream, client: 203.0.113.2, server: example.com, request: "GET /dev/ HTTP/1.1", upstream:
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There are no processes listening on 80 or 443 port:
# netstat -tunlp | grep -E “:80|:443”
Cause
Nginx service is not running.
Resolution
Note: To apply further instructions, it is required to have administrative access to Plesk. If you don’t have Tools & Settings (Server settings) menu, please contact your server’s administrator or hosting company support that can manage your server.
Start nginx service under Plesk > Tools & Settings > Services Management > Reverse Proxy Server (nginx):
Note: in case nginx is missing, install it according to the article.
Alternatively, nginx can be started via the command-line interface:
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Connect to the server via SSH.
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Run the following command:
# service nginx restart