Symptoms
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Website is loading continuously without showing any errors.
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After a huge amount of time, loading can fail with the following error:
500 - Internal Server Error
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No other errors can be observed.
Cause
Application Pool misconfiguration that leads to an inability to spawn the worker process.
Resolution
Re-create the application pool:
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Go to Domains > example.com > Dedicated IIS Application Pool for Website
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Click on Switch Off, and then to Switch On to recreate the pool
Note: In case Application Pool is shared between all domains of the subscription, apply the steps above to the primary domain of the subscription.
In case the issue persists, it is also required to re-create the site in IIS:
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Log in to the server via RDP.
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Identify what Application Pool is the website assigned to via IIS > Sites > example.com > View Applications > Application Pool:
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Remove the site from IIS by right click on it and press Remove.
Warning: in case the site was using plesk(default) application pool, skip step 4 and proceed with step 5.
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Remove the application pool that was identified on step 2 via IIS > Application Pools > example.com(domain).
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Re-create the site and application pool, on Plesk server it is possible with the following command executed via the command line:
C:> plesk repair web example.com