Symptom
-
When logging in to webmail or a mail client, the email list does not show up. Instead, one of the following error messages appears:
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in Horde:
PLESK_ERROR: could not open mail inbox
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in Roundcube:
PLESK_ERROR: Server Error: STATUS: Internal error occurred.
-
-
One of the following error messages appears in
/var/log/maillog
:PLESK_INFO: dovecot: service=pop3, [email protected], ip=[]. Error: Index is read-only, can’t write-lock /var/qmail/mailnames/example.com/john_doe/Maildir/dovecot.index.log
PLESK_INFO: dovecot: service=lda, [email protected], ip=[]. Error: sieve: failed to open logfile (LOGGING TO STDERR): open(/var/qmail/mailnames/example.com/john_doe/.dovecot.sieve.log) failed: Permission denied (euid=30(popuser) egid=31(popuser) UNIX perms appear ok (ACL/MAC wrong?))
PLESK_INFO: Error: open(/var/qmail/mailnames/example.com/john_doe/Maildir/dovecot-uidlist) failed: Permission denied Aug 4 16:47:26 cloud1 dovecot: service=lda, [email protected], ip=[]. msgid=<[email protected]>: save failed to INBOX: Internal error occurred. Refer to server logfor more information.
- If the mailbox is set up in new a mail client, POP3 authorization fails.
Cause
Incorrect ownership on Dovecot files: The owner/group should be popuser:popuser
Resolution
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Connect to the Plesk server via SSH.
-
Change owner and group toÂ
popuser:popuser
for all Dovecot files that have incorrect ownership:# find /var/qmail/mailnames/ -name dovecot* -exec chown popuser:popuser {} ;
- If this does not help, run:
# chown popuser:popuser -R /var/qmail/mailnames/Â