Symptoms
Unable to set SmarterMail as default mail server due to an error:
Error: Unable to set SmarterMail Server 203.0.113.2 as the default Mail Server: defpackagemng failed: Unable to assign port to IP address.
Reason:
Unknown IP Address:
(Error code 1)
OR
 Error: Unable to set SmarterMail Server as the default Mail Server: defpackagemng failed: AssignPortToIP(203.0.113.2) failed: Error code -2. Error message: Unknown IP Address:
at (SMSvcUtil::checkActionResult line 66)
Cause
MailEnable was not properly stopped.
Resolution
It is required to stop MailEnable completely in order to activate SmarterMail. For that:
- Log into the server via RDP.
- Open Plesk Services Monitor from tray and stop all services of MailEnable.
- Try enabling SmarterMail once again.
- If the step above did not help, do the following:
- Open registry by typing
regedit
in the CMD. - Change HKLM > Software > Wow6432Node > Plesk > PSA Config > Config > MAIL_PROVIDER_DLL parameter with path to Plesk
smartermailprovider.dll
library, for exampleC:Program Files (x86)ParallelsPleskadminbinsmartermailprovider.dll
- In HKLM > Software > Wow6432Node > Plesk > PSA Config > Config > Packages > Mailserver set Default to
smartermail
- In Tools & Settings > Server Components click Refresh button
- Open registry by typing
- Try adding Enabling SmarterMail once again.