Symptoms
- Some subscriptions are not receiving emails from Google, Outlook, etc.
- Following errors are found in
C:Program Files (x86)Mail EnableLoggingSMTPSMTP-Debug-<date>.txt
MailEnable log file:...
ME-I0148: [0F95DD61854F47A5A79AE4974C40BB02.MAI] DATE (DATA Termination) command failed with temporary return code.
ME-E0034: [0F95DD61854F47A5A79AE4974C40BB02.MAI] DATA command returned with a 421 response, meaning that the entire message should be retried.
SSL recv failed: socket has was closed gracefully by peer before this recv [1412]
...
ME-I0070: [CC0FF2408468408D8C46F4915CFF2824.MAI] (recv) socket [1956] was gracefully closed during [RCPT] command by the remote client 203.0.113.3.
ME-I0074: [1956] (Debug) End of conversation
...
ME-I0070: (recv) socket [1036] was gracefully closed during [AUTH] command by the remote client 203.0.113.2.
SSL recv failed: socket has was closed gracefully by peer before this recv [1956]
... - Invalid SSL certificate is used to secure Mail server connections in Plesk > Tools & Settings > SSL/TLS Certificates:
- Checking with openssl utility provides following errors:
# openssl s_client -connect plesk.example.com:25 -starttls smtp
CONNECTED(00000003)
didn’t found starttls in server response, try anyway…
# openssl s_client -showcerts -connect plesk.example.com:465
socket: Connection refused
connect:errno=111
Cause
Invalid certificates and DNS servers are configured in MailEnable.
Resolution
- Login into Plesk GUI
- Secure Mail server with a valid certificate:Â How to secure mail server with Let’s Encrypt certificate?
- Connect to the server via RDP
- Ensure valid DNS servers are set in MailEnable > Servers > localhost > Services and Connectors > Right click on SMTP > Properties > Change DNS servers, use a realiable DNS servers such as Google DNS servers with IP
8.8.8.8
and8.8.4.4
> Apply changes > Right click on SMTP > Stop > Right click on SMTP > Start