Symptoms
Unable to provide Plesk support with server access via SSH access extension with the following error message:
PLESK_ERROR: Failed to provide access: Cannot whitelist IP address: Binary sa-firewall_iptables.sh execution failed with error code 3; stdout [] stderr [ip6tables v1.4.21: can’t initialize ip6tables table `filter’: Address family not supported by protocol Perhaps ip6tables or your kernel needs to be upgraded. ]
Cause
IPv6 is disabled on the server. Plesk Support SSH extension refuses to work on the servers without the IPv6 module.
This is the Support SSH extension bug with ID #EXTCERT-3482 that will be fixed in one of the future updates.
Resolution
Until the bug is fixed use the following workaround:
-
Install the Panel.ini Editor from the Extensions menu in Plesk.
-
Open Panel.ini Editor at Extensions > My Extensions.
-
In Panel.ini Editor, switch to the Editor tab. If the editor is empty, do the following:
3.1. Download the panel_ini.txt file.
3.2. Open the downloaded file and copy its content.
3.3. Paste the content into the editor.
-
Add the following content and click Save:
[ext-support-access]
supportAddresses = 195.214.233.155/24
The same workaround can be also applied locally on the server:
Via SSH shell on a Linux server
-
Connect to a Plesk server via SSH.
-
Сheck “panel.ini” availability:
# ls -l /usr/local/psa/admin/conf/panel.ini
-
If the file
/usr/local/psa/admin/conf/panel.ini
does not exist or is empty, create it by copying the sample configuration file/usr/local/psa/admin/conf/panel.ini
:# cp /usr/local/psa/admin/conf/panel.ini.sample /usr/local/psa/admin/conf/panel.ini
-
-
Open the file
/usr/local/psa/admin/conf/panel.ini
in any text editor. In this example, we are using the vi editor:# vi /usr/local/psa/admin/conf/panel.ini
-
Add the following to the
panel.ini
file:[ext-support-access]
supportAddresses = 195.214.233.155/24 -
Save the changes and close the file. Changes will be applied immediately, no service restart is required.
On a Windows server via RDP
-
Connect to a Plesk server via RDP.
-
Open the file
panel.ini
located in the folder%plesk_dir%adminconf
(Just paste this path in Windows Explorer to open) in any text editor.- If the
panel.ini
file does not exist, create it by copying the sample configuration filepanel.ini.sample
.
- If the
-
Add the following to the
panel.ini
file:[ext-support-access]
supportAddresses = 195.214.233.155/24 -
Save the changes and close the file. Changes will be applied immediately, no service restart is required.