Symptoms
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When creating an additional domain or a subdomain inside an existing subscription, the operation fails with:
PLESK_ERROR: Error: skelmng failed: Access is denied. (Error code 5) at CreateDirectory(C:Inetpubvhostsexample.comsub.example.comcss)
<…>
PLESK_ERROR: Error: skelmng failed: Access is denied. (Error code 5) at retrieves attributes for file or directory C:Inetpubvhostsexample.comsub.example.com
<…> -
When changing a PHP version in Plesk, the operation fails with the error “Access denied” and one of the errors above appear in the logfile
C:Program Files (x86)Pleskadminlogsphp_error.log
.
Cause
Web-space (subscription) security settings are corrupted.
Resolution
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Connect to the Plesk server via RDP.
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In the commands below, replace example.com with an affected subscription name and run:
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Repair the web-space security settings of the subscription:
C:> “%plesk_cli%repair.exe” –repair-webspace-security -webspace-name example.com
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Reconfigure subscription:
C:> “%plesk_cli%repair.exe” –reconfigure-web-site -web-site-name example.com
-
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Create an additional domain or a subdomain again.
Note: If all subscriptions in Plesk are affected, apply the solution from this KB article.