Symptoms
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Unable to continue DigiCert order instructions provided by email:
Thank you for your order! To finish the issuing of your SSL certificate, follow these steps:
Log in to Plesk.
Go to Websites & Domains > domain name for which you have purchased the certificate > DigiCert SSL.
Scroll down to the corresponding Orders for Domain section and click Order. -
The SSL It! and DigiCert SSL extensions are installed and enabled in Plesk > Extensions > My Extensions
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It is not possible to complete the order, only appears options to purchase a new DigiCert SSL certificate instead to complete the billed order under Plesk > Domains > example.com > SSL/TLS Certificates
Cause
This is SSL It! extension bug ID #EXTSSLIT-361 which will be fixed in future Plesk updates.
Resolution
As a workaround:
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Go to Extensions > My Extensions > SSL It! extension > More > Disable
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Go to Domains > example.com > DigiCert SSL > Scroll down to the billed/ready to order > Click Order and follow the instructions to complete the order:
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Once the DigiCert SSL order is completed, go to Extensions > My Extensions > SSL It! extensions > More > Enable