Symptoms
-
Unable to configure External SMTP Server with a non-email address login in Tools & Settings > External SMTP Server, the following error is shown:
PLESK_ERROR: Error: Unable to encode IDN email address ‘jdoe’: email address is invalid
-
The relay mail server configured in Tools & Settings > External SMTP Server only accepts authentication with non-email address login. For example, it only accepts connection with the username
jdoe
instead of[email protected]
 email address.
Cause
This is a Plesk bug with ID #PPP-46097 which will be fixed in future Plesk updates.
Note: Subscribe to this article to get notified once a fix will become available
Resolution
Configure a non-email address login in External SMTP Server with the following workaround:
-
Connect to the server via RDP
- Start a command prompt as Administrator
-
C:> plesk db dump psa > C:psa.backup.sql
-
Set the non-email address login directly on the database:
C:> plesk db -e “update servicenodeconfiguration set value = ‘jdoe’ where serviceNodeId = 1 and section = ‘MailGate’ and name = ‘login'”
* Where
jdoe
is the username used to authenticate with the external relay mail server configured in Tools & Settings > External SMTP Server