Symptoms
-
It is not possible to create a subscription user or open Plesk File Manager with one of the following error messages in Plesk:
PLESK_ERROR: Error: System user update is failed: Unable to create system user: Unable to execute usermng: no such table: ImpersonationUsers
PLESK_ERROR: Error: System user update is failed: Unable to create system user: Unable to execute usermng: attempt to write a readonly database at execute console command –add(vconsoleapp::start line 93) at execute “C:Program Files (x86)ParallelsPleskadminbinusermng” –add “–name=plesktest” “–password=*” “–home=C:/Inetpub/vhosts/example.com”(vconsoleapp::run line 110) (Error code 1)
-
Manual synchronization of impersonation storage with the Plesk database may fail:
C:> “%plesk_cli%repair.exe” –synchronize-impersonation-storage
usermng failed: attempt to write a readonly database
at execute console command –sync-impersonation-cache(vconsoleapp::start line
93)
at execute “C:Program Files (x86)ParallelsPleskadminbinusermng” –sync-
impersonation-cache “–config=usrC195.tmp”(vconsoleapp::run line 110)
(Error code 1) -
Migration may fail with one of the mentioned errors.
Cause
Product issue:
-
#PPP-52706 "Errors encountered during Plesk update are now correctly recorded in the installer log."
Fixed in:- Plesk Obsidian 20 July 2021 (Windows)
Resolution
Workaround
If update is not possible for some reason you may try the following
workaround
Until the issue is resolved, use the following workaround:
-
Connect to the Plesk server via RDP.
-
Download the empty database scheme.
-
Go to
%plesk_dir%admindb
(just paste this path in Windows Explorer to open) and create a copy of the originalImpersonationCache.db
file. -
Replace the original
ImpersonationCache.db
file with the downloaded. -
Start a command prompt as an Administrator and run the following command to sync impersonation storage with the Plesk database:
C:> “%plesk_cli%repair.exe” –synchronize-impersonation-storage