Symptoms
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On a Plesk for Windows server, the subscription example.com has a database on the remote MS SQL server which is shown as unavailable in Plesk in Tools & Settings > Database Servers.
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The domain example.com is disabled in Plesk. The following error message appears on the attempt to activate it in Domains > example.com > Activate:
PLESK_ERROR: Error: Some of the selected domains or aliases were not activated.
Unable to activate the domain: Either the domain owner or their subscription is suspended. -
The following error message appears on the attempt to activate the customer which owns the subscription example.com in Plesk in Customers > John Doe > Activate:
PLESK_ERROR: Error: Some of the selected customers were not suspended.
Try to establish connection failed
Cause
Product issue:
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#PPPM-8931 “Customers can now be suspended and activated without issue even if one or more subscriptions owned by the customer have a remote SQL database server configured and that database server is not available.”
Fixed in:- Plesk Obsidian 08 May 2019 (fixed as PPP-37491)
Resolution
Workaround
If update is not possible for some reason, use the workaround:
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Connect to the server using RDP.
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Execute the following query to activate the domain example.com:
UPDATE domains SET status = 0 WHERE name = 'example.com';
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Execute the following queries to find webspace ID and activate the subscription:
Find the webspace ID:
SELECT IF(d2.id IS NOT NULL, d2.id, d.id) AS 'Webspace ID' FROM domains d LEFT JOIN domains d2 ON d.webspace_id = d2.id WHERE d.name = 'example.com'; +-------------+ | Webspace ID | +-------------+ | 123313 | +-------------+ 1 row in set (0.00 sec)
Update the webspace statuses using the ID from the previous query:
UPDATE domains SET webspace_status = 0 WHERE id = 123313 OR webspace_id = 123313;