Symptoms
- While accessing Plesk >Tools & Settings > IP Address Banning (Fail2Ban), one of the following errors appear:
PLESK_ERROR: Internal error: f2bmng failed: ERROR:f2bmng:Timeout of 10 seconds has been reached. Lock ‘service.fail2ban’ is already owned by another process with pid <unknown>
or
PLESK_ERROR: 502 Bad Gateway
or
PLESK_ERROR: ERROR Failure failed to parse timeText
-
Unable to remove subscription in Plesk. The following error appears inÂ
panel.log
:Internal error: f2bmng failed: ERROR:f2bmng:Timeout of 10 seconds has been reached. Lock 'service.fail2ban' is already owned by another process with pid <unknown>
-
If there are no errors shown at Plesk >Tools & Settings > IP Address Banning (Fail2Ban), the following record appears inÂ
/var/log/plesk/panel.log
:stderr: ERROR:__main__:Timeout of 10 seconds has been reached. Lock 'service.fail2ban' is already owned by another process with pid <unknown>
-
The license is in grace period even though it was updated/renewed correctly on a licensing server side:
PLESK_WARN: You are currently operating within the grace period of your product license. To update your product license, select the Retrieve Keys option on the License Management page.
-
While trying to retrieve/install keys at the page Plesk > Tools & Settings > License Management it does not load and fails with the following error:
PLESK_ERROR: 504 Gateway Time-out (nginx)
Cause
Corrupted Fail2ban packages. When Plesk backend tries to get the service status for fail2ban, the process hangs and returns a timeout error.
Resolution
-
Log into Plesk
-
Stop Fail2Ban service in Plesk >Â Tools & Settings > Services Management.
-
Connect to the server via SSH
-
Remove all Fail2Ban logs:
# rm -f /var/log/fail2ban*
-
Open Plesk UI, go to Tools & Settings > Updates & upgrades > Add/remove componetns > reinstall Fail2Ban component