Symptoms
On a Plesk for Linux server, the log file /var/log/maillog
contains different errorsÂ
NOQUEUE: reject: RCPT from
:
-
plesk.example.com postfix/smtpd[18336]: NOQUEUE: reject: RCPT from unknown[203.0.113.2]: 554 5.7.1 <unknown[203.0.113.2]>: Client host rejected: Access denied; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<domain.com>
-
plesk.example.com postfix/smtpd[26537]: NOQUEUE: reject: RCPT from some.unknown.domain.com[203.0.113.2]: 454 4.7.1 <[email protected]>: Relay access denied; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<some.unknown.domain.com>
-
plesk.example.com postfix/smtpd[29579]: NOQUEUE: reject: RCPT from unknown[203.0.113.2]: 550 5.1.1 <[email protected]>: Recipient address rejected: User unknown in virtual mailbox table; from=<[email protected]> to=<[email protected]> proto=ESMTP helo=<SOM-PC>
Cause
- The error
Client host rejected: Access denied
means that a client could not use allowed authentication methods.ÂNote: it could be caused by a misconfiguration:
https://support.plesk.com/hc/en-us/articles/213364749 - The error
Relay access denied
 means that a client tried to use a server as a relay, but the settings are too restrictive.Note: it could be caused by a misconfiguration. To change relay settings, use the option Tools & Settings > Mail Server Settings > Relay options.
- The errorÂ
Recipient address rejected: User unknown in virtual mailbox table
 means that somebody tried to send mail to the nonexistent user.
Resolution
Most of the time no actions need to be performed since the mail works the way it is supposed to work.