Symptoms
- The site fails to open with 403 Forbidden error via HTTPS (or 404 Not Found);
- There are the following records in
/var/www/vhosts/example.com/logs/error_log
file:(13)Permission denied: /var/www/vhosts/example.com/httpsdocs/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable, referer: https://www.example.com
OR
AH01276: Cannot serve directory /var/www/vhosts/example.com/httpsdocs/: No matching DirectoryIndex (index.php) found, and server-generated directory index forbidden by Options directive
OR
-
The domain example.com displays different data when accessing using HTTP and HTTPS;
-
The domain shows the default Apache welcome page or website shows Plesk default page;
-
Path of Document Root for a domain changes on each reconfiguration from /httpdocs to /httpsdocs: the “root” statement in the file
points to /httpsdocs instead of /httpdocs
/var/www/vhosts/system/example.com/conf/nginx.conf
-
Document Root is set to /httpdocs in Plesk > Domains > example.com > Hosting Settings > Document Root;
-
Plesk was upgraded from the older version where the Document root was changed from split location (http in /httpdocs and https in /httpsdocs) using Separate SSL/TLS and non-SSL/TLS content option.
Cause
Enabled compatibility mode for the legacy option “Separate SSL/TLS and non-SSL/TLS content“
Resolution
- Log into Plesk.
- Disable the mode under Plesk > Domains > example.com > Hosting Settings > uncheck Run the website in compatibility mode for the legacy option “Separate SSL/TLS and non-SSL/TLS content