Symptoms
- When loading Plesk the following error is displayed:
HTTP Error 503. The service is unavailable
- In Event Viewer > Windows Logs > Application the following error:
The Module DLL C:Program Files (x86)iisnodeiisnode.dll failed to load. The data is the error.
- PleskControlPanel Application pool is stopped at IIS Manager > server > Application Pools
Cause
Plesk users psaadm and psacln do not have access to
directory by default.
C:Program Files (x86)iisnode
Resolution
-
Connect to the server via RDP.
-
Add the following lines into the
disksecurity.xml
file which is stored in%plesk_dir%etcDiskSecurity
directory:<!-- Program Filesiisnode -->
<Entry AccounType="1" Account="Psaadm" Path="{ProgramFiles}" SubPath="iisnode" AceFlags="ThisFolderSubfoldersAndFiles" AccessMask="Read" EntryFlags="0x40" />
<Entry AccounType="1" Account="Psacln" Path="{ProgramFiles}" SubPath="iisnode" AceFlags="ThisFolderSubfoldersAndFiles" AccessMask="Read" EntryFlags="0x40" /> -
Open Plesk Reconfigurator by running the following command in cmd:
C:> “%plesk_dir%adminbinreconfigurator.exe”
-
Correct disk permissions:
OR
Repair Plesk Installation > tick checkbox Plesk File Security > Check. -
Start Plesk Services Monitor:
-
Restart Plesk Management Service
-
Start PleskControlPanel application pool at IIS > server > Application Pools > PleskControlPanel > Start