Symptoms
-
Plesk Premium Antivirus does not detect infected emails.
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Antivirus protection is enabled for an email account at Domains > example.com > [email protected] > Antivirus.
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The Plesk Premium Antivirus is shown as running at Tools & Settings > Services Management.
Cause
Mail filters are disabled/misconfigured in the Postfix configuration.
Resolution
-
Connect to the Plesk server via SSH.
-
Open the file
/etc/postfix/main.cf
in a text editor. In this example, we are using the vi editor:# vi /etc/postfix/main.cf
-
Adjust the
smtpd_milters
andnon_smtpd_milters
(if exists) parameters the following way:Note: Make sure that these parameters are not commented with # at the beginning of the line.
smtpd_milters = , inet:127.0.0.1:12768
non_smtpd_milters = -
Save the changes and close the file.
-
Verify the changes:
# grep -ir milters /etc/postfix/main.cf
smtpd_milters = , inet:127.0.0.1:12768
non_smtpd_milters = -
Restart the postfix, pc-remote, drwebd services:
# service postfix restart
# service pc-remote restart
# service drwebd restart