Symptoms
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Plesk is not accessible:
PLESK_INFO: HTTP Error 500.0 – Internal Server Error
C:Program Files (x86)Pleskadminenginephp-cgi.exe – The FastCGI process exited unexpectedly -
Accessing Plesk directly on the server via RDP the following detailed information is shown:
Server Error
500 PleskLockException
Lock Manager error: 'Unable to create file: C:/Program Files (x86)/Plesk/var/locks/authorizer.lock: Permission denied'.
Cause
Missing user psaadm_users for the folder and all the subfolder/files of C:/Program Files (x86)/Plesk/var/locks/
Resolution
Note: Another solution is to use the Plesk Reconfigurator > Check components and folders permissions > Select Plesk. But it will take quite a lot.
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Connect to the server via RDP
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Open properties of C:/Program Files (x86)/Plesk/var/locks/ folder mentioned in the error and switch to the Security tab.
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Add the username psaadm_users with all the permission as allow:
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Click Ok to save.