Symptoms
New Plesk is not accessible after cloning VPS as is or after a disaster recovery. The following error is shown:Â
PLESK_INFO: ERROR: Zend_Db_Adapter_Exception: SQLSTATE[HY000] [1045] Access denied for user ‘admin’@’localhost’ (using password: NO) Additionally, an exception has occurred while trying to report this error: Zend_Exception No entry is registered for key ‘translate’ (Abstract.php:144);
Cause
Plesk does not recognize the old admin password after such method of server cloning.
Resolution
Note: Refer to the Deploying Plesk Servers by Cloning Plesk documentation for the proper instructions regarding cloning servers with Plesk.
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Connect to the server via SSH;
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Reset the admin password via the command:
# plesk bin admin -p -passwd ‘<password>’
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If the error below shows up when login in via admin and password (not via
# plesk login
):PLESK_INFO: PleskFatalException: Unable to obtain secret key for passwords encryption
Use the command below to regenerate the encryption key (the following error can be ignored):
# /usr/local/psa/admin/sbin/encrypt_keygen
Unable to generate new key – key file exists
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