Symptoms
- Email notifications (e. g. about scheduled tasks) are not delivered to remote mailbox.
- Plesk notifications are sent from exampleserver.com
- Plesk mail server is configured to use example.net as SMTP relay.
- Error in
:
/var/log/maillogpostfix/qmgr[3743]: B9F7E30001FD: [email protected], size=992, nrcpt=1 (queue active)
in.l.exampleserver.com[203.0.113.2]:25, delay=5, delays=0.02/3.5/1.1/0.41, dsn=5.7.1, status=bounced (host smtp-in.exampleserver.com[203.0.113.2] said: 550-5.7.1 Unauthenticated email from example.net is not accepted due to 550-5.7.1 domain's DMARC policy. Please contact the administrator of 550-5.7.1 example.net domain if this was a legitimate mail.Â
Cause
exampleserver.com is not configured to use example.net mailbox as return-path address.
Resolution
Note: specify actual mail addresses in the configuration directives below
- Connect to Plesk server using SSH
- Add the following line to the bottom of
/etc/postfix/main.cf
:smtp_generic_maps = hash:/etc/postfix/generic
- Create
/etc/postfix/generic
with the following content:[email protected] [email protected]
-
Generate address map:
# postmap /etc/postfix/generic
-
Restart Postfix:
# service postfix restart