Symptoms
-
After restoring Plesk due to disaster. Mail stopped working;
-
The following error can be found in
:
/var/log/maillogdovecot_authdb_plesk[5239]: No such user '[email protected]' in mail authorization database
(
mchk
) utility does not restore authentication database. The below errors can be found in Plesk logs
/usr/local/psa/admin/sbin/mchk
:
/var/log/plesk/panel.logERR [panel] Non-UTF data for mail account: [email protected]
Cause
Mailbox passwords can not be decrypted with the
on a new server
/etc/psa/private/secret_key
Resolution
Replace secret key with the one from the old server
-
Log in to Plesk server using SSH
-
Backup the original key:
# cp /etc/psa/private/secret_key /etc/psa/private/secret_key.orig
-
Restore the secret key from the old server, put it in the correct directory /etc/psa/private/secret_key and rerun mchk utility:
# cp /etc/psa/private/secret_key /etc/psa/private/secret_key.orig
# cp /old/etc/psa/private/secret_key /etc/psa/private/secret_key
Perform a reset of all of the email accounts passwords
-
Download and unzip the script:
# wget https://support.plesk.com/hc/en-us/article_attachments/360009603299/plesk_password_changer_onyx.zip
# unzip plesk_password_changer_onyx.zip
-
Reset passwords for Plesk users and email accounts:
# /usr/local/psa/bin/sw-engine-pleskrun plesk_password_changer_onyx `cat /etc/psa/.psa.shadow` –mailaccounts