Symptoms
- Plesk is running behind CloudFlare
- Certain pages (e.g Mail Server Settings, License Management at Tools & Settings) shows blank pages when logged into Plesk using hostname
- Customer/reseller interfaces show blank pages when logged into Plesk using hostname
Cause
Product issue:
- #PPPM-12844 “Plesk Obsidian 18.0.34 and later behind Cloudflare with Rocket Loader enabled for a domain no longer shows empty customers’ and resellers’ pages. Note: Although the issue was fixed, we recommend that you disable Rocket Loader. It does not benefit Plesk in any way.”
Fixed in:- Plesk Obsidian 25 March 2021
- Plesk Obsidian 23 March 2021
Resolution
Please consider updating your server:
Workaround
If the update is not possible for some reason you may try the following
workaround
Until fix available apply workaround:
- Login to the server via SSH;
- Backup original configuration:
# mv /usr/local/psa/admin/plib/CommonPanel/View/Helper/Plesk.php{,.backup}
- Download patch and move it into corresponding directory:
# wget https://plesk.zendesk.com/hc/article_attachments/360023710499/Plesk.php
# cp Plesk.php /usr/local/psa/admin/plib/CommonPanel/View/Helper/Plesk.php