Symptoms
- Log files have incorrect (old) timestamps after system time or timezone was changed in Plesk > Tools & Settings > System Time.
- The
date
command shows the correct system time.
Cause
This is the expected behavior after the time or timezone changing, the restart of the services is required.
Resolution
Note: to apply new time and timezone for all services simultaneously, reboot the server.
- Log into the server via SSH.
- Apply the new time and timezone for log files by restarting the corresponding services, for example:
- For
/var/log/plesk/panel.log
restart psa service:# service psa restart
- For
/var/log/messages
and/var/log/maillog
restart rsyslog service:# service rsyslog restart
- For
/var/log/nginx/error.log
restart Nginx service:# service nginx restart
- For
/var/log/httpd/error_log
or/var/log/apache2/error.log
restart Apache service:# service httpd restart 2> /dev/null || service apache2 restart 2> /dev/null
- For
/var/log/cron
restart thersyslog
andcrond
services:# service rsyslog restart
# service crond restart
- For