Symptoms
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Plesk license was not automatically updated on a server with one of the following messages:
PLESK_WARN: Warning: You are currently operating within the grace period of your product license. To update your product license, select the Retrieve Keys option on the License Management page.
PLESK_WARN: Your license key has expired. To continue using your Plesk, you must purchase a non-expiring commercial license key.
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The following message is received by Plesk administrator:
Unable to update EXT.12345678.1234: an error occurred while processing your key. You can try to retrieve the key manually in Plesk (Tools & Settings > License Management) or let Plesk try to update it in the next 24 hours. If you do not want to receive this notification any more, remove this key from Plesk.
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The following errors can be found in the
/var/log/plesk/panel.log
file:ERR [panel] KeyUpdate Result code: 2 Network failure
ERR [panel] KeyUpdate Result desc: Not valid XML. XML parsing failed
ERR [panel] KeyUpdate Result code: 2 Network failure
ERR [panel] KeyUpdate Result desc: Not valid XML. no element found
TLSv1.2 (OUT), TLS header, Certificate Status (22): > SSL data removed for security reason
* TLSv1.2 (OUT), TLS handshake, Client hello (1): > SSL data removed for security reason
* Unknown SSL protocol error in connection to ka.plesk.com:5224 * Closing connection 0 cURL verbose output:
* Could not resolve host: ka.plesk.com * Closing connection 0
Cause
The corrupted file /etc/sw/keys/registry.xml
 or Plesk licensing server (Key Administrator) is overloaded with the same requests.
Resolution
Apply one of the following solutions, depending on Plesk configuration:
Standalone Plesk (Plesk without Multi Server)
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Connect to the server via SSH.
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Remove the
/etc/sw/keys/registry.xml
file:# rm /etc/sw/keys/registry.xml
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Log out and log into Plesk again to recreate the removed
/etc/sw/keys/registry.xml
file. -
Run Daily Maintenance task to update keys on the server:
# /usr/local/psa/admin/bin/php /usr/local/psa/admin/plib/DailyMaintainance/task-script.php UpdateKeys –period=daily
Plesk Multi Server
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Go to Plesk Management Node > Nodes > 203.0.113.2 and click the Manage Node link.
Note: the affected node has the Unsupported value in the status column
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Navigate to License Management and click the Retrieve Keys button.
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Back to the Management Node > Nodes > 203.0.113.2 and click Re-Check link.