Symptoms
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The following warning appears at Tools & Settings > Mail Server Settings and Domains > example.com > Mail Settings even though the SMTP ports are not blocked:
PLESK_WARN: You cannot send emails from Plesk because outbound connections on TCP ports 25 and 587 are blocked.
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telnet
shows that the ports are open:# telnet smtp.gmail.com 25
Trying 172.253.112.108…
Connected to smtp.gmail.com.
Escape character is ‘^]’.
220 smtp.gmail.com ESMTP q130sm18788818ywg.52 – gsmtp# telnet smtp.gmail.com 587
Trying 172.253.112.109…
Connected to smtp.gmail.com.
Escape character is ‘^]’.
220 smtp.gmail.com ESMTP y206sm19186865ywa.102 – gsmtp -
iptables
shows thatpsaadm
does not have permissions for outbound SMTP connections:# iptables -L SMTPOUTPUT
ACCEPT tcp — anywhere anywhere multiport dports smtp,urd,submission owner GID match mail
ACCEPT tcp — anywhere anywhere multiport dports smtp,urd,submission owner UID match popuser
ACCEPT tcp — anywhere anywhere multiport dports smtp,urd,submission owner UID match postfix
ACCEPT tcp — anywhere anywhere multiport dports smtp,urd,submission owner UID match root
LOGDROPOUT tcp — anywhere anywhere multiport dports smtp,urd,submission
Cause
Product issue:
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#PPPM-11528 “The check on SMTP ports 25 and 587 can no longer return false-positive results.”
Fixed in:- Plesk Obsidian 17 March 2020 (Linux)
Resolution
Workaround
If update is not possible for some reason you may try the following
workaround
The warning can be safely closed and ignored.