Symptoms
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Plesk Premium Email extension by Kolab is used in Plesk.
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Non-default SSL certificate is set to secure mail traffic at Plesk > Tools & Settings > SSL Certificates > Certificate for securing mail;
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Email traffic still uses Plesk Default certificate: How to verify that SSL for IMAP/POP3/SMTP works and a proper SSL certificate is in use;
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/etc/dovecot/private/dovecot.pem
and/etc/dovecot/private/ssl-cert-and-key.pem
files have different content:# md5sum /etc/dovecot/private/ssl-cert-and-key.pem /etc/dovecot/private/dovecot.pem
232dd0e418d073758357452c825eafc1 /etc/dovecot/private/ssl-cert-and-key.pem
5641ddb15e79c0fda43bcd7a5d5dc307 /etc/dovecot/private/dovecot.pem
Cause
This is a Plesk bug with ID PPPM-7808 which is planned to be fixed in future product updates.
Resolution
for Kolab version 16.3.0 and earlier:
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Connect to the server using SSH.
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Overwrite
/etc/dovecot/private/ssl-cert-and-key.pem
with content from/etc/dovecot/private/dovecot.pem
:# cp -f /etc/dovecot/private/dovecot.pem /etc/dovecot/private/ssl-cert-and-key.pem
for Kolab version 16.3.3:
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Connect to the server via SSH.
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Restart guam service:
# service guam stop
# service guam start
Note: as a workaround for Kolab version 16.3.2 upgrade to version 16.3.3.