Symptoms
After upgrading Plesk on Windows or after changing the admin password, the following error is shown instead of the Plesk login page:
Access denied for user 'admin'@'localhost' (using password: YES)
Cause
An incorrect password is set for the user admin
in the MySQL database.
Resolution
-
Connect to the server via RDP
-
Open
cmd.exe
as Administrator and create the password registry entry, specifying a new password:C:> plesk sbin psadb -u –password=”new_password”
-
Add the
skip-grant-tables
option in[PleskSQLServer]
section of the file%plesk_dir%MySQLmy.ini
:. . .
[PleskSQLServer]
skip-grant-tables
. . . -
restart the Plesk SQL Server service:
C:> net stop PleskSQLServer && net start PleskSQLServer
-
Change the admin password in the database:
C:> plesk db “update mysql.user set authentication_string=password(‘new_password‘) where user=’admin'”
-
Remove the
skip-grant-tables
from%plesk_dir%MySQLmy.ini
and restart the service again (repeat step #3). -
Run the following commands in Command Prompt to update the password in Windows registry:
C:> plesk sbin psadb -u –password=”new_password”
plesk sbin psadb -s –password=”new_password”