Symptoms
-
The extension DigitalOcean DNS is installed and configured
-
A newly created subdomain is not resolved globally by DigitalOcean nameservers:
# dig +trace sub.example.com
…
example.com. 1750 IN SOA ns1.digitalocean.com. host.example.com. 1585681781 10800 3600 604800 1800
;; Received 100 bytes from 198.41.222.173#53(203.0.113.2) in 100 ms
Cause
Expected behavior.
DNS zone in Plesk for a subdomain is not enabled automatically after the creation. There was nothing to synchronize with DigitalOcean DNS.
Resolution
In case subdomain should have its own DNS zone
- Log into Plesk
- Activate the DNS zone for the subdomain in Domains > sub.example.com > DNS Settings > Enable​
- Activate zone in the DigitalOcean DNS extension in DigitalOcean DNS > select sub.example.com > Activate
In case subdomain should be within the domain’s zone
- Log into Plesk
- Go to DigitalOcean DNS > example.com
- Press the Resync button
Vote for the request to enable the DNS zone automatically for newly created subdomains.
The top-ranked suggestions are likely to be included in the next versions of Plesk.