Symptoms
- DKIM DNS records are not added to the DNS zone.
- DKIM support is not enabled either on server or domain level.
Cause
It is the expected behavior. Plesk adds DKIM DNS records in case DKIM support is enabled only.
Resolution
-
To enable a possibility of DKIM signing of outgoing email server-wide:
Go to Plesk > Tools & Settings > Mail Server Settings > DKIM spam protection and select Allow signing outgoing mail:
-
 To enable DKIM signing of outgoing email for an individual domain:
Go to Plesk > Subscriptions > example.com > Mail tab > Mail Settings tab (select the domain name if there are several) and select Use DKIM spam protection system to sign outgoing email messages:
If it was already enabled, re-enable it by unchecking the checkbox Use DKIM spam protection system to sign outgoing email messages and checking it again.
Note: DKIM signing works only for domains that use the Plesk’s DNS server. The DNS service must be activated on a domain.