Symptoms
Changes made to the TTL values of a particular DNS record in Plesk are not synchronized to DigitalOcean by DigitalOcean DNS extension. For example in Domains > example.com > DNS Settings > clicking on A record for example.com > TTL:
Cause
Such behaviour was confirmed as a DigitalOcean DNS extension bug with ID #EXTPLESK-2272. This will be fixed in future extension updates.
Resolution
As a workaround perform one of the following:
Workaround 1
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Set a TTL value for the entire zone in Domains > example.com > DNS Settings > Settings tab > Zone defaults: TTL.
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Click on Apply.
Workaround 2
Apply changes to the specific DNS record on DigitalOcean’s side.
Note: Such a change may be reverted as soon as Plesk syncs data with DigitalOcean.