Symptoms
-
Messages cannot be sent to remote mail servers, a bounce message is returned instead:
MailEnable: Message could not be delivered to some recipients.
The following recipient(s) could not be reached:
Recipient: [SMTP:<...>@example.com]
Reason: The message could not be delivered because the domain name (example.com) does not appear to be valid. -
The following can be observed in the MailEnable SMTP Debug log (
%plesk_dir%Mail ServersMail EnableLoggingSMTPSMTP-Debug-<date>.log
):MF-E0039: [<...>.MAI] DNS Lookup failure (11001): Domain mail.example.com does not exist.
ME-E0060: [<...>.MAI] - Message could not be delivered to target domain (example.com). Message returned to Sender.
MF-E0039: [<...>.MAI] DNS Lookup failure (11002): Could not resolve domain mx.example.com to IP address. -
It is not possible to resolve mail server from the command line:
C:> nslookup mail.example.com
Server: UnKnown
Address: 192.168.0.2*** UnKnown can’t find mail.example.com: Unspecified error
Cause
Default DNS resolver does not work correctly, and therefore mail server is unable to send message to remote ones.
Resolution
- Connect to the server via RDP
- Change DNS servers in the network adapter configuration to public ones, such as 8.8.4.4 and 8.8.8.8: Google Public DNS: Get Started