Symptoms
-
Plesk Email Security extension is installed on Plesk.
-
Messages are not sent out with the following records in Â
/var/log/maillog
:plesk postfix/error[4438]: 541055E94: to=<[email protected]>, relay=none, delay=16313, delays=16312/0.1/0/0, dsn=4.4.1, status=deferred (delivery temporarily suspended: connect to 127.0.0.1[127.0.0.1]:10024: Connection refused)
-
/var/log/plesk/panel.log
contains the following error:Trying to restart service amavis... attempt to restart service amavis - service doesn't exist (missing unit file or not executable control script)
Cause
Product issues:
-
#EXTCERT-3031 “Changed the ordering of the ClamAV removal call in the installation process.”
Fixed in:- Plesk Email Security 1.1.3 14 August 2020 (Linux)
-
#EXTCERT-3048 “Now the component will not be configured during update if the components’s installation has not been completed by a user.”
Fixed in:- Plesk Email Security 1.1.4 18 August 2020 (Linux)
Resolution
Please consider updating your server:
Workaround
If update is not possible for some reason you may try the following
workaround
As a workaround perform the following steps:
-
Connect to the server via SSH
-
Unset content filter from Postfix:
# postconf content_filter=”
-
Restart postfix service:
# systemctl restart postfix
-
Requeue all mails in queue:
# postsuper -r ALL
If the issue still persist, reinstall Plesk Email Security extension How to manage Plesk extensions (install, disable, remove, update)