Symptoms
-
A Plesk-hosted website shows either of the following errors:
ERR_NAME_RESOLUTION_FAILED
ERR_NAME_NOT_RESOLVED
-
Domain name cannot be resolved with
SERVFAIL
error:# host example.com 8.8.8.8
Using domain server:
Name: 8.8.8.8
Address: 8.8.8.8#53
(…)
Host example.com not found: 2(SERVFAIL) -
Tracing the DNS query shows that authoritative NS servers cannot be accessed:
# dig +short +trace example.com @8.8.8.8
NS g.root-servers.net. from server 8.8.8.8 in 64 ms.
(…)
NS c.root-servers.net. from server 8.8.8.8 in 64 ms.
dig: couldn’t get address for ‘ns1.examplens.com’: no more -
Authoritative NS servers do not have A records:
# host ns2.examplens.com
Host ns2.examplens.com not found: 3(NXDOMAIN)# host ns1.examplens.com
Host ns1.examplens.com not found: 3(NXDOMAIN) -
The domain can be resolved if a query is performed directly to the IP address of the server. In this example, the server’s IP is 203.0.113.2:
# host example.com 203.0.113.2
Using domain server:
Name: 203.0.113.2
Address: 203.0.113.2#53
Aliases:
example.com has address 203.0.113.2
example.com mail is handled by 10 mail.example.com.
Cause
Domain’s authoritative NS servers have no “A” DNS records, therefore DNS cannot resolve them to run a query.
Resolution
-
If authoritative NS servers (
ns1.examplens.com
andns2.examplens.com
) are hosted in Plesk:- Log into Plesk
- Go to Domain > examplens.com > DNS Settings
- Add A records
ns1
andns2
with server’s IP address, as per the Knowledge Base article: How to add a DNS record for a domain in Plesk
-
If authoritative NS servers (
ns1.examplens.com
andns2.examplens.com
) are not hosted on Plesk:Contact the domain registrar or DNS provider for assistance to add “A” record onÂ
ns1
andns2
records side.