Symptoms
-
When repairing Plesk database under Tools & Settings > Diagnose & Repair > Plesk Database > Repair, the following error is shown:
PLESK_WARN: 0 issue(s) fixed.
Repair Kit fixed all issues it could. If any issues were not fixed, please try fixing them manually or contact Plesk Support.
WARNING Checking the consistency of the Plesk database Inconsistency in the table ‘dns_recs’ for the column dns_zone_id: No rows in the table ‘dns_zone’ with = 3 (13 broken references) -
The following error is found in the
/var/log/plesk/panel.log
log file with Plesk debug mode enabled:...
{"id":3,"cmd":"plesk repair db -y","type":"warning","message":"Checking the consistency of the Plesk database","level":0,"details":"Inconsistency in the table 'dns_recs' for the column dns_zone_id: No rows in the table 'dns_zone' with = 3 (13 broken references)"}
{"id":4,"cmd":"plesk repair db -y","type":"progress","message":"Creating a database dump","level":1}
{"id":5,"cmd":"plesk repair db -y","type":"info","message":"Execution failed.nCommand: /usr/local/psa/bin/mysqldump.shnArguments: Arrayn(n [0] => --titlen [1] => preresolven)nnDetails: file does not exist or is not executable: /usr/local/psa/bin/mysqldump.sh","level":1}
, stderr:
Cause
Product issue:
-
#EXTPLESK-1570 "Repair Kit now actually fixes the database inconsistencies."
Fixed in:- Repair Kit 1.2.3 27 January 2021
Resolution
Workaround
If update is not possible for some reason you may try the following
workaround
As a workaround, fix the database inconsistencies following these steps:
-
Connect to the server via SSH.
-
Run the following command:
# plesk repair db -y