Symptoms
Unable to rename the subscription in Plesk with the error below:
PLESK_ERROR: Error: ftpmng failed: The system cannot find the file specified. (Error code 2) at GetLongPathName(‘C:Inetpubvhostsexample.comdomain.tld’) at (VFileName::longFileName line 253) at addUser(192.0.2.1, jdoe, C:Inetpubvhostsexample.comdomain.tld)(IIsFtp7ServerAdapter::addUser line 411) at reconfFtpUser(jdoe)(FtpServerManager::reconfFtpUser line 482) at updateUsers()(FtpServerManager::updateUsers line 168) at Unable to execute console command: ‘–update-users'(vconsoleapp::start line 95) at Unable to execute command: ‘”C:Program Files (x86)Pleskadminbin64ftpmng” –update-users “–config=C:/Program Files (x86)/Plesk/PrivateTemp/ftu46defa6b.tmp” –soft'(vconsoleapp::run line 117) (Error code 1)
Cause
The folder of a domain domain.tld
under the subscription example.com
is missing.
Note: The issue might be related to subdomains as well (i.e. C:Inetpubvhostsexample.comsub.example.com
).
Resolution
Create missing folder manually:
- Log into Plesk
- Go to Domains > example.com > File Manager > Home directory
- Click
button > Create Directory
- Create the missing folder
domain.tld
- Try to rename the subscription once again